CI3.0.6的session功能在php7.1中无法使用

最近将自己使用的php版本升级到了7.1,但是随后就发现自己的博客项目无法登录进去了。调试后发现,每次登录时session总是被自动删除了,感觉是CI的session类有bug,百度了一下,发现https://aslibra.com/blog/read.php/1840.htm这篇文章做出了详细的解释。

解决的办法就是将session文件更新为3.1.7版本

书山有路勤为径 学海无涯苦作舟